A feature in Wordfence isn't working. What could be causing that?

From Wordfence Documentation
Jump to: navigation, search

We've found that there are unfortunately many badly written plugins out there that break certain features in WordPress and therefore prevent Wordfence from working. The easiest way to isolate which plugin is causing the issue is to disable all plugins except Wordfence and then reenable them one by one until one of them breaks Wordfence. Some examples of problems we've seen are:

  • Plugins that try to protect your /wp-admin/ area but in doing so block access to the WordPress AJAX handler which lives in that directory and needs to be publicly accessible.
  • Plugins that put your site into maintenance mode and also disable the AJAX handler in wp-admin.
  • Plugins that generate javascript errors. These errors prevent any other javascript from executing on the same page. So if you have a plugin generating javascript errors in your administrative area, Wordfence won’t work. Check your browser javascript error console for errors if you’re having a problem. In Chrome on Mac you can click “View / Developer / Javascript Console” to see javascript errors (or click HERE). Note which file is generating the error.
  • Plugins that disable jQuery in WordPress. For some reason there seem to be several plugins that completely break jQuery. This disables Wordfence and almost all other plugins and themes that rely on this core library.

Please note that the Wordfence team can’t provide support for other plugins, however if you’re aware of a specific incompatibility please report it to us.